[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

[Openvpn-users] Fwd: Can someone please help, client + subnet, server + subnet.


  • Subject: [Openvpn-users] Fwd: Can someone please help, client + subnet, server + subnet.
  • From: Paul <riainp@xxxxxxxxx>
  • Date: Wed, 19 Jul 2006 14:34:27 +0100

Hey guys, this really is stumping me. I am fighting with this every day for 2 weeks now. :(

OpenVPN Server Routes.

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
10.8.0.2        *               255.255.255.255 UH    0      0        0 tun0
xxx.xxx.231.0   10.8.0.2        255.255.255.128 UG    0      0        0 tun0
192.168.70.0    *               255.255.255.0   U     0      0        0 eth0
10.8.0.0         10.8.0.2        255.255.255.0   UG    0      0        0 tun0
192.168.1.0     *               255.255.255.0   U     0      0        0 eth1
default         192.168.1.1      0.0.0.0         UG    0      0        0 eth1

OpevVPN Client Routes. (I'm not sure of the topology of this side)

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
10.8.0.5         *               255.255.255.255 UH    0      0        0 tun0
192.168.70.0    10.8.0.5        255.255.255.0   UG    0      0        0 tun0
10.8.0.0         10.8.0.5        255.255.255.0   UG    0      0        0 tun0
xxx.xxx.231.0   *               255.255.255.0    U     0      0        0 eth0
127.0.0.0       *               255.0.0.0       U     0      0        0 lo
default         xxx.xxx.231.1   0.0.0.0          UG    0      0        0 eth0

xxx.xxx.231.xxx = public ip of network. (And of server)


---------------------

I have a Router. Behind this router is a machine with 2 interfaces, eth0 and eth1. eth0 connects to the router, behind eth1 is a subnet ( 192.168.70.0). This is my side, the side i control so lets call this A.


Across the internet i have for all intensive purposes the same setup. (in reality its a little different but not relevant) Lets call this side B.

Now.

If i run the server on A and the client on B, then the clients behind B can contact my clients behind A. But my clients behind A cannot contact the clients behind B. This works vice versa if i run the server on B and the client on A.

I have read the readmes, i have trawled through the mailing list, i have looked at inumberable numbers of examples. I have added the Client-config-dir, i have pushed the routes, we have tried this on windows and on Linux and we simply cannot get this to work.

Can someone please take a look at our 2 configuration files (client and server are attached with some addresses replaced) and see if they automatically see anything wrong.

And maybe if its simply syntax or something is this right ?
In the folder "ccd" we have a file called "client" which contains the line iroute 192.168.70.0 255.255.255.0 which points to my subnet at A. (This is assuming the server is running on B of course)

client-config-dir /etc/openvpn/config/ccd
route 192.168.70.0 255.255.255.0

Perhaps its simply a routing problem, but please can someone take a look. We have being fighting with this for nearly 2 weeks non-stop.

Thank you.




Attachment: client.config
Description: Binary data

Attachment: server.config
Description: Binary data

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys -- and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users