[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

[Openvpn-users] I need some help with bridging


  • Subject: [Openvpn-users] I need some help with bridging
  • From: Jose Luis Gonzalez <joseluis@xxxxxxxxxxx>
  • Date: Thu, 06 Oct 2005 11:04:10 +0200

Hello all list member.

I'm sure this question was posted before, so please, sorry about it.

I've successfully set up a routed OpenVPN connection with two Windows XP. Now I'm trying to change it to a bridged connection. I followed the windows bridge how-to:
    -uncomment the dev-node line and address the windows tap
    -change server line to server-bridge
    - create a windows bridge with the openvpn tap and the network interface

I'm using the windows gui by mathias sundman to start and stop the connection.

The recently created windows tap-bridge stay unconnected, such as in routed configuration, but after starting the vpn server it remains unconnected (at the routed vpn it changed to connected and reported an ip address).
Is this right? If not, what is going on?
The OpenVPN shows a suspicious note, but it reports that the initialization sequence is completed, but the client is unable to connect.
Of course I checked several times the configuration file to match the same name of the windows tap.

Thanks in advance.

Here is my server config:

port 1194
proto tcp
dev tap
dev-node "tap-bridge"
ca "C:\\Archivos de programa\\OpenVPN\\config\\server\\ca.crt"
cert "C:\\Archivos de programa\\OpenVPN\\config\\server\\server.crt"
key "C:\\Archivos de programa\\OpenVPN\\config\\server\\server.key"
dh "C:\\Archivos de programa\\OpenVPN\\config\\server\\dh1024.pem"
ifconfig-pool-persist ipp.txt
server-bridge 172.26.0.197 255.255.255.0 172.26.0.190 172.26.0.196
keepalive 10 120
comp-lzo
persist-key
persist-tun
status openvpn-status.log
verb 3

And the server log:

Thu Oct 06 10:20:50 2005 OpenVPN 2.0.2 Win32-MinGW [SSL] [LZO] built on Aug 25 2005
Thu Oct 06 10:20:50 2005 Diffie-Hellman initialized with 1024 bit key
Thu Oct 06 10:20:50 2005 TLS-Auth MTU parms [ L:1576 D:140 EF:40 EB:0 ET:0 EL:0 ]
Thu Oct 06 10:20:51 2005 TAP-WIN32 device [tap-bridge] opened: \\.\Global\{B55D240C-1076-4F96-AA59-00AC6A77DD90}.tap
Thu Oct 06 10:20:51 2005 TAP-Win32 Driver Version 8.1
Thu Oct 06 10:20:51 2005 TAP-Win32 MTU=1500
Thu Oct 06 10:20:51 2005 Sleeping for 10 seconds...
Thu Oct 06 10:21:01 2005 NOTE: could not get adapter index for \DEVICE\TCPIP_{B55D240C-1076-4F96-AA59-00AC6A77DD90}, status=55 : El recurso de red o el dispositivo especificados ya no se encuentran disponibles. 
# The message could be translated to: The network resource or given device are not longer available.

Thu Oct 06 10:21:01 2005 Data Channel MTU parms [ L:1576 D:1450 EF:44 EB:135 ET:32 EL:0 AF:3/1 ]
Thu Oct 06 10:21:01 2005 Listening for incoming TCP connection on [undef]:1194
Thu Oct 06 10:21:01 2005 TCPv4_SERVER link local (bound): [undef]:1194
Thu Oct 06 10:21:01 2005 TCPv4_SERVER link remote: [undef]
Thu Oct 06 10:21:01 2005 MULTI: multi_init called, r=256 v=256
Thu Oct 06 10:21:01 2005 IFCONFIG POOL: base=172.26.0.190 size=7
Thu Oct 06 10:21:01 2005 IFCONFIG POOL LIST
Thu Oct 06 10:21:01 2005 MULTI: TCP INIT maxclients=60 maxevents=64
Thu Oct 06 10:21:01 2005 Initialization Sequence Completed

--

JPEG image