[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

[Openvpn-users] routing problem


  • Subject: [Openvpn-users] routing problem
  • From: joshua <jsanten@xxxxxxxxx>
  • Date: Wed, 22 Jun 2005 09:01:42 +0000 (UTC)

Hi,

I succesfully installed openvpn on a linux box.
My clients are able to connect to it, but i have a routing problem

The vpn server has an local ip adres of 192.168.1.2 subnet 255.255.255.0
The vpn server tun ip adress is 192.168.2.1 subnet 255.255.255.0
I ve got an NAT router which has an ip of 192.168.1.3 subnet 255.255.255.0

The vpn clients are able to ping 192.168.2.1 (the ip of the vpn server) but not 
able to ping to 192.168.1.2 and none of the other machines in the local network.

ip_forward is set to 1 on the server.

in the server config file i put the following lines:
server 192.168.2.0 255.255.255.0
ifconfig-pool-persist ipp.txt
push "dhcp-option DNS 192.168.1.3"
push "dhcp-option DOMAIN jsanten.org"
push "route 192.168.2.0 255.255.255.0 192.168.1.2"

but in the client log i see the following lines:
Notified TAP-Win32 driver to set a DHCP IP/netmask of 
192.168.2.6/255.255.255.252 on interface {57D608D8-74F8-4A3B-BD5E-F0049AC0C220} 
[DHCP-serv: 192.168.2.5, lease-time: 31536000]
route ADD 192.168.2.0 MASK 255.255.255.0 192.168.1.2
route ADD 192.168.2.0 MASK 255.255.255.0 192.168.2.5  
what should be the routing rules? im confused, i tried several rules, without 
succes. 

Joshua




____________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users