[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

[Openvpn-users] server not receiving disconnect


  • Subject: [Openvpn-users] server not receiving disconnect
  • From: Matt Wilks <matt@xxxxxxxxxxxxxxxxxxxxxxx>
  • Date: Wed, 20 Oct 2004 15:15:47 -0400

I've got OpenVPN 2.0b11 running in server mode accepting connections.
Connecting from and XP box running the same version and Mathias' gui
gives me no problems except upon disconnect.  It appears that the server
does not receive a disconnect message when sent from the client, as I am
still getting spew like below into the log file.  Also, there are not
disconnect messages logged in the log.  It doesn't work even if I
side-step the gui and start it directly from a right-click on the conf
file.

This becomes a problem when using the client-connect and
client-disconnect scripts.  client-disconnect isn't called until the
server is restarted and as a result, client-connect is only called the
first time a user logs in.  I have verified that restarting the server
disconnects all users, calling the client-disconnect script for each and
allows new connections to be made again.

Is this a bug in beta 11 that is fixed in later releases?


============

Wed Oct 20 15:05:21 2004 us=357998  event_wait returned 0
Wed Oct 20 15:05:21 2004 us=358026 I/O WAIT status=0x0020
Wed Oct 20 15:05:21 2004 us=358039 MULTI: REAP range 96 -> 112
Wed Oct 20 15:05:21 2004 us=358066 wilksm/ip.of.rem.mach:5000 TLS: tls_multi_process: i=0 state=S_NORMAL, mysid=03b39d7e f496bcd8, stored-sid=c38e87b0 34be8d7d, stored-ip=ip.of.rem.mach:5000
Wed Oct 20 15:05:21 2004 us=358081 wilksm/ip.of.rem.mach:5000 TLS: tls_process: chg=0 ks=S_NORMAL lame=S_UNDEF to_link->len=0 wakeup=604800
Wed Oct 20 15:05:21 2004 us=358092 wilksm/ip.of.rem.mach:5000 STATE S_NORMAL
Wed Oct 20 15:05:21 2004 us=358105 wilksm/ip.of.rem.mach:5000 ACK reliable_can_send active=0 current=0 : [40]
Wed Oct 20 15:05:21 2004 us=358129 wilksm/ip.of.rem.mach:5000 ACK reliable_send_timeout 604800 [40]Wed Oct 20 15:05:21 2004 us=358141 wilksm/ip.of.rem.mach:5000 TLS: tls_process: timeout set to 3374
Wed Oct 20 15:05:21 2004 us=358161 wilksm/ip.of.rem.mach:5000 TLS: tls_multi_process: i=1 state=S_INITIAL, mysid=ee7a04dc cc7e4866, stored-sid=00000000 00000000, stored-ip=[undef]
Wed Oct 20 15:05:21 2004 us=358181 wilksm/ip.of.rem.mach:5000 TLS: tls_multi_process: i=2 state=S_UNDEF, mysid=00000000 00000000, stored-sid=00000000 00000000, stored-ip=[undef]
Wed Oct 20 15:05:21 2004 us=358198 wilksm/ip.of.rem.mach:5000 RANDOM USEC=155075
Wed Oct 20 15:05:21 2004 us=358216 wilksm/ip.of.rem.mach:5000 SCHEDULE: schedule_add_modify wakeup=[Wed Oct 20 15:05:36 2004 us=513283] pri=2139419762
Wed Oct 20 15:05:21 2004 us=358235 SCHEDULE: schedule_find_least wakeup=[Wed Oct 20 15:05:36 2004 us=513283] pri=474532103
Wed Oct 20 15:05:21 2004 us=358249 PO_CTL rwflags=0x0001 ev=4 arg=0x0807e2dc
Wed Oct 20 15:05:21 2004 us=358261 PO_CTL rwflags=0x0001 ev=5 arg=0x0807e2e0
Wed Oct 20 15:05:21 2004 us=358276 I/O WAIT TR|Tw|SR|Sw [10/0] 

-- 
Matthew Wilks
University of Toronto        Computing and Networking Services
(416) 978-3328               matt@xxxxxxxxxxxxxxxxxxxxxxx
4 Bancroft Ave., Rm. 102     Toronto, ON  M5S 1C1

____________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users