[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

Re: [Openvpn-users] OpenVPN 2 beta 4 Windows Port in use...


  • Subject: Re: [Openvpn-users] OpenVPN 2 beta 4 Windows Port in use...
  • From: "Erik Anderson" <erikba@xxxxxxxxxxxxxxxxx>
  • Date: Thu, 10 Jun 2004 14:18:44 -0700

I've had this issue myself.  I belive that port 5000 is within the "dynamic
port area", which means that it can be assigned to applications that don't
care what port they get (similar to OpenVPN using the "nobind" option).
Some applications, like FTP, change ports with every transaction they make
which means that the lifetime of a dynamic port assignment can sometimes be
measured in seconds.  Running a port monitor after the fact is not likely to
get any answers if this is what is happening.

----- Original Message ----- 
From: "Sam Dunham" <samdunham@xxxxxxx>
To: "OpenVPN Users List" <openvpn-users@xxxxxxxxxxxxxxxxxxxxx>
Sent: Thursday, June 10, 2004 2:02 PM
Subject: Re: [Openvpn-users] OpenVPN 2 beta 4 Windows Port in use...


> On Wed, 9 Jun 2004 22:38:39 +0200 (CEST), "Mathias Sundman"
> <mathias@xxxxxxxxxx> said:
> > On Wed, 9 Jun 2004, Sam Dunham wrote:
> >
> > > Here is the log output:
> > >
> > > Wed Jun 09 12:36:57 2004 OpenVPN 2.0_beta4 Win32-MinGW [SSL] [LZO]
built
> > > on Jun  8 2004
> > > Wed Jun 09 12:36:57 2004 Control Channel MTU parms [ L:1541 D:138
EF:38
> > > EB:0 ET:0 EL:0 ]
> > > Wed Jun 09 12:36:57 2004 TCP/UDP: Socket bind failed on local address
> > > [undef]:5000: Address already in use (WSAEADDRINUSE)
> > > Wed Jun 09 12:36:57 2004 Exiting
> > >
> > > The problem is the last few lines (obviously). I have no idea how the
> > > address can already be in use. And any suggestions would be greatly
> > > appreciated.
> >
> > You don't just happend to have another instance of openvpn running in
> > another window or as a service?
> >
> > You really should try to find out what is binding to port 5000, but if
> > you
> > don't care, you can add the option --nobind to your client config. That
> > causes openvpn to just pick a free sourceport to use.
> >
> > I use this option anyway because I don't see any use in having the
> > clients
> > listening on a dedicated port, as I'm usually connecting from behind a
> > NAT
> > device, so the client can't be reached from the server anyway.
> >
> > This allows me to run more than one openvpn tunnel at the same time
> > without having to worry about the problem you have.
> >
> > -- 
> > _____________________________________________________________
> > Mathias Sundman                  (^)   ASCII Ribbon Campaign
> > NILINGS AB                        X    NO HTML/RTF in e-mail
> > Tel: +46-(0)8-666 32 28          / \   NO Word docs in e-mail
>
> Okay, thanks for that tip. I added the "nobind" parameter to my config
> file and gave it another shot. No more "poert in use" error. ^^ I did
> download a port monitor before I tried that, though and the only process
> using port 5000 was OpenVPN. When I stopped the service, that port was no
> longer in use. When I started it, it was the only process using that
> port. Anyway, like I said, I took your suggestion and addded "nobind" to
> my config file. Now I get the following in my log file and it still
> doesn't work:
>
> --------------------------------------------------------------------------
-----------------------------------
>
> Thu Jun 10 16:52:06 2004 OpenVPN 2.0_beta4 Win32-MinGW [SSL] [LZO] built
> on Jun  8 2004
> Thu Jun 10 16:52:07 2004 Control Channel MTU parms [ L:1541 D:138 EF:38
> EB:0 ET:0 EL:0 ]
> Thu Jun 10 16:52:07 2004 Data Channel MTU parms [ L:1541 D:1450 EF:41
> EB:0 ET:0 EL:0 ]
> Thu Jun 10 16:52:07 2004 Local Options String: 'V3,dev-type tun,link-mtu
> 1541,tun-mtu 1500,proto UDPv4,cipher BF-CBC,auth SHA1,keysize
> 128,key-method 2,tls-client'
> Thu Jun 10 16:52:07 2004 Expected Remote Options String: 'V3,dev-type
> tun,link-mtu 1541,tun-mtu 1500,proto UDPv4,cipher BF-CBC,auth
> SHA1,keysize 128,key-method 2,tls-server'
> Thu Jun 10 16:52:07 2004 Local Options hash (VER=V3): 'a0f1c7ed'
> Thu Jun 10 16:52:07 2004 Expected Remote Options hash (VER=V3):
> 'b319fa3e'
> Thu Jun 10 16:52:07 2004 Socket Buffers: R=[8192->65536] S=[8192->65536]
> Thu Jun 10 16:52:07 2004 UDPv4 link local: [undef]
> Thu Jun 10 16:52:07 2004 UDPv4 link remote: 66.83.79.2:5000
> Thu Jun 10 16:52:07 2004 read UDPv4: Invalid argument (WSAEINVAL)
> (code=10022)
> Thu Jun 10 16:52:07 2004 TLS: Initial packet from 166.83.79.2:5000,
> sid=98e16f9e a0d0dfa5
> Thu Jun 10 16:52:07 2004 VERIFY OK: depth=1,
> /C=US/ST=SC/L=Charleston/O=S3BLaw/emailAddress=samdu@xxxxxxxxxxxxx
> Thu Jun 10 16:52:07 2004 VERIFY OK: depth=0,
> /C=US/ST=SC/O=S3BLaw/CN=S3BLawServer/emailAddress=samdu@xxxxxxxxxxxxx
> Thu Jun 10 16:52:08 2004 Data Channel Encrypt: Cipher 'BF-CBC'
> initialized with 128 bit key
> Thu Jun 10 16:52:08 2004 Data Channel Encrypt: Using 160 bit message hash
> 'SHA1' for HMAC authentication
> Thu Jun 10 16:52:08 2004 Data Channel Decrypt: Cipher 'BF-CBC'
> initialized with 128 bit key
> Thu Jun 10 16:52:08 2004 Data Channel Decrypt: Using 160 bit message hash
> 'SHA1' for HMAC authentication
> Thu Jun 10 16:52:08 2004 Control Channel: TLSv1, cipher TLSv1/SSLv3
> EDH-RSA-DES-CBC3-SHA, 1024 bit RSA
> Thu Jun 10 16:52:08 2004 [S3BLawServer] Peer Connection Initiated with
> 66.83.79.2:5000
> Thu Jun 10 16:52:09 2004 SENT CONTROL [S3BLawServer]: 'PUSH_REQUEST'
> (status=1)
> Thu Jun 10 16:52:09 2004 PUSH: Received control message:
> 'PUSH_REPLY,route 10.8.0.1 255.255.255.255,ping 10,ping-restart
> 60,ifconfig 10.8.0.6 10.8.0.5'
> Thu Jun 10 16:52:09 2004 OPTIONS IMPORT: timers and/or timeouts modified
> Thu Jun 10 16:52:09 2004 OPTIONS IMPORT: --ifconfig/up options modified
> Thu Jun 10 16:52:09 2004 OPTIONS IMPORT: route options modified
> Thu Jun 10 16:52:09 2004 Attempting to lock Win32 semaphore
> 'openvpn_netcmd' prior to net shell command (timeout = 600 sec)
> Thu Jun 10 16:52:09 2004 CreateFile failed on TAP device:
> \\.\Global\{A9F84FC3-5B83-432F-A936-04CBE39E3194}.tap: General failure
> (ERROR_GEN_FAILURE) (errno=31)
> Thu Jun 10 16:52:09 2004 Exiting
>
> --------------------------------------------------------------------------
--------------------------------------
> -- 
>   Sam Dunham
>   samdunham@xxxxxxx
>
> -- 
> http://www.fastmail.fm - A no graphics, no pop-ups email service
>
>
> -------------------------------------------------------
> This SF.Net email is sponsored by the new InstallShield X.
> From Windows to Linux, servers to mobile, InstallShield X is the
> one installation-authoring solution that does it all. Learn more and
> evaluate today! http://www.installshield.com/Dev2Dev/0504
> _______________________________________________
> Openvpn-users mailing list
> Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
> https://lists.sourceforge.net/lists/listinfo/openvpn-users
>


____________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users