[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

[Openvpn-users] Cannot allocate TUN/TAP dev dynamically


  • Subject: [Openvpn-users] Cannot allocate TUN/TAP dev dynamically
  • From: Vincent Freeman <vincentfreeman30@xxxxxxxxxxx>
  • Date: Sun, 18 Apr 2004 20:01:52 +0100 (BST)

I have OpenVPN installed on my Fedora server and my
Macos 10.3 laptop as the client (with tunnel-1.2.1
installed and loaded).

Intranet network is 192.168.0.0 mask 255.255.255.0
fedora eth0: 192.168.0.252
fedora eth1 (pretend this is my public ip):
192.168.1.1
Macos en0 (my client machine): 192.168.1.2


My config file (static-home.conf) is:

dev tap
remote 192.168.1.1
ifconfig 192.168.0.10 255.255.255.0
up ./home.up
secret static.key
comp-lzo
verb 3


When I run "sudo openvpn --config static-home.conf" I
get the following:

0: OpenVPN 1.6_rc4 powerpc-apple-darwin7.3.0 [SSL]
[LZO] built on Apr 18 2004
1: Static Encrypt: Cipher 'BF-CBC' initialized with
128 bit key
2: Static Encrypt: Using 160 bit message hash 'SHA1'
for HMAC authentication
3: Static Decrypt: Cipher 'BF-CBC' initialized with
128 bit key
4: Static Decrypt: Using 160 bit message hash 'SHA1'
for HMAC authentication
5: LZO compression initialized
6: Cannot allocate TUN/TAP dev dynamically
7: Exiting

I ran kextload and got "kextload:
/System/Library/Extensions/tunnel.kext loaded
successfully" so I know the tunnel is working and the
devices are there.

Any ideas as to why it isn't working?

Thanks,

Vincent.


	
	
		
____________________________________________________________
Yahoo! Messenger - Communicate instantly..."Ping" 
your friends today! Download Messenger Now 
http://uk.messenger.yahoo.com/download/index.html

____________________________________________
Openvpn-users mailing list
Openvpn-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-users