[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

[Openvpn-users] openvpn newbie needs routing help ;-)


  • Subject: [Openvpn-users] openvpn newbie needs routing help ;-)
  • From: "Brett Meehan" <repudi8or@xxxxxxxxxxx>
  • Date: Thu, 22 Jan 2004 15:32:23 +1100

Hi list,

I just stumbled across openvpn and would like to try to use this to establish a connection from my work (win2k - behind a restrictive http proxy) to my home pc (redhat 7.3 - broaband connection to the internet) to get clear channel bandwidth so i can run msn messenger and net games, etc. FYI I have only a small level of tcp/ip networking knowledge. I am using openvpn 1.5.0 on both ends.

I have managed to establish a openvpn tun (routing) connection over an ssh tunnel to my home pc but the routes to get out to the internet have me confused. The infrastructure looks sort of like the attached jpeg



My current problem is that I can connect to everything on my home network (192.168.0 subnet) but nothing on the internet. The routing on my gateway currently looks like this:-
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
192.168.1.2 0.0.0.0 255.255.255.255 UH 40 0 0 tun0
192.168.0.0 0.0.0.0 255.255.255.0 U 40 0 0 eth1
211.x.x.0 0.0.0.0 255.255.255.0 U 40 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 40 0 0 lo
0.0.0.0 211.x.x.1 0.0.0.0 UG 40 0 0 eth0


I figure there is some additional route needed to allow packets from 192.168.1 subnet to route correctly to 211.x.x subnet and back again. I just cant work out what it is, since everything works fine to the 192.168.0 subnet.

Any help would be appreciated

Regards Repudi8or

_________________________________________________________________
Hot chart ringtones and polyphonics. Go to http://ninemsn.com.au/mobilemania/default.asp

Attachment: tunnel.jpg
Description: JPEG image