[OpenVPN home] [Date Prev] [Date Index] [Date Next]
[OpenVPN mailing lists] [Thread Prev] [Thread Index] [Thread Next]
Google
 
Web openvpn.net

[Openvpn-devel] Small slash patch


  • Subject: [Openvpn-devel] Small slash patch
  • From: Gisle Vanem <giva@xxxxxxxxx>
  • Date: Tue, 15 Feb 2005 18:50:16 +0100

Using '\' in #include<> messes up the dependency generation (gcc -MM ..).
Or at least MingW's make doesn't like it. So could you please use Unix slashes.

--- CVS-latest\cryptoapi.c      Sun Nov 28 18:22:01 2004
+++ cryptoapi.c Sun Jan 23 09:31:06 2005
@@ -32,8 +32,8 @@
#include <stdio.h>
#include <ctype.h>
#include <assert.h>
-#include <openssl\ssl.h>
-#include <openssl\err.h>
+#include <openssl/ssl.h>
+#include <openssl/err.h>

#ifdef __MINGW32_VERSION
/* MinGW w32api is incomplete when it comes to CryptoAPI, as per version 3.1

--gv

____________________________________________
Openvpn-devel mailing list
Openvpn-devel@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/openvpn-devel